PV Distribution
Posted by Elumalai M at 1:43 AM 0 comments-Edge, middle, center, inner-middle, inner-edge. These are the different regions where a logical volume can live. Using different distributions will give you different types of performance.
Example:
-Put things that need fast, sequential access on the edge. This moves the disk media under the read head at a faster rate. Though, the outer edge is slow at random access because of the distance the read head must move.
-Put things that need fast, random access on the inner edge, the read head needs to move less to find data on this area.
Paging Space
Posted by Elumalai M at 1:31 AM 0 comments
Before creating the additional paging:
# lsps -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type Chksum
paging00 hdisk7 rootvg 8832MB 1 yes yes lv 0
hd6 hdisk7 rootvg 512MB 1 yes yes lv 0
#
Create LV for Paging:
#mklv -y paging01 -t paging rootvg 128 hdisk14
paging01
Add to paging:
# swapon /dev/paging01
#lsps -s
Total Paging Space Percent Used
17536MB 1%
# lsps -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type Chksum
paging01 hdisk7 rootvg 8192MB 1 yes no lv 0
paging00 hdisk7 rootvg 8832MB 1 yes yes lv 0
hd6 hdisk7 rootvg 512MB 1 yes yes lv 0
#
What is paging space?
–Virtual Memory
–Memory and paging space both composed of“pages”
-Memory and paging space are divided into four kilobyte chunks called pages (or page frames). There should always be at least one page of paging space for each page of physical memory.
-Data in memory that is not being used can be “paged out” to paging space to make room for other data
-Access to paging space is, since it is on a disk, slow in comparison to memory access
To view the paging spaces on a node:
#ls -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type
paging01 hdisk2 db2wh01vg 1024MB 10 yes yes lv
hd6 hdisk0 rootvg 512MB 20 yes yes lv
Removing a paging space:
Set to not activate on reboot
chps –a n.
Reboot
shutdown -Fr
Remove paging space:
rmps
(OR)
with AIX version 5.1 and above, paging spaces can be removed on-the-fly.
Starting with AIX 5.1, paging space can be added and removed on the fly.
To deactive a paging space immediately in AIX 5.1+, use the swapoff command.
This will move any data stored in that paging space to other paging spaces and immediately deactivate the paging space.
If there is not enough room in other paging spaces to hold the contents of the paging space being swapped off, the command will fail.
# lsps -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type Chksum
paging00 hdisk7 rootvg 8832MB 1 yes yes lv 0
hd6 hdisk7 rootvg 512MB 1 yes yes lv 0
#
Create LV for Paging:
#mklv -y paging01 -t paging rootvg 128 hdisk14
paging01
Add to paging:
# swapon /dev/paging01
#lsps -s
Total Paging Space Percent Used
17536MB 1%
# lsps -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type Chksum
paging01 hdisk7 rootvg 8192MB 1 yes no lv 0
paging00 hdisk7 rootvg 8832MB 1 yes yes lv 0
hd6 hdisk7 rootvg 512MB 1 yes yes lv 0
#
What is paging space?
–Virtual Memory
–Memory and paging space both composed of“pages”
-Memory and paging space are divided into four kilobyte chunks called pages (or page frames). There should always be at least one page of paging space for each page of physical memory.
-Data in memory that is not being used can be “paged out” to paging space to make room for other data
-Access to paging space is, since it is on a disk, slow in comparison to memory access
To view the paging spaces on a node:
#ls -a
Page Space Physical Volume Volume Group Size %Used Active Auto Type
paging01 hdisk2 db2wh01vg 1024MB 10 yes yes lv
hd6 hdisk0 rootvg 512MB 20 yes yes lv
Removing a paging space:
Set to not activate on reboot
chps –a n
Reboot
shutdown -Fr
Remove paging space:
rmps
(OR)
with AIX version 5.1 and above, paging spaces can be removed on-the-fly.
Starting with AIX 5.1, paging space can be added and removed on the fly.
To deactive a paging space immediately in AIX 5.1+, use the swapoff
This will move any data stored in that paging space to other paging spaces and immediately deactivate the paging space.
If there is not enough room in other paging spaces to hold the contents of the paging space being swapped off, the command will fail.
Types of Volume Groups and Limitaion
Posted by Elumalai M at 12:03 AM 0 comments
Volume
Groups have 3 different types:
VG type Max PVs Max LVs Max PPs per VG Maximum PP size
Normal VG 32 256 32,512 (1016 * 32) 1 GB
Big VG 128 512 130,048 (1016 * 128) 1 GB
Scalable VG 1024 4096 2,097,152 128 GB
Note: Scalable VG AIX 5.3 and above, PV and LV limitations can be defined by the administrator.
Subscribe to:
Posts (Atom)